
 
 

 

INFILTRATION MODULE—ENERGYPLUS EXERCISE INSTRUCTIONS 

Exercise Introduction and Objectives 

The exercise provides a base file for a two-story building, measuring 104 x 48. The building is 
modeled with core and perimeter zoning for each floor.  

The objective of this exercise is to study the effect of infiltration on a building’s energy use. 
EnergyPlus contains three models for basic infiltration calculations.  

 The first is the Design Flow Rate model that was inherited from EnergyPlus’s 
predecessor programs. It is based on environmental conditions modifying a design flow 
rate.  

 The second is the Effective Leakage Area model based on Sherman and Grimsrud (1980).  

 The third is the Flow Coefficient model based on Walker and Wilson (1998).  
 
The model formulations for the Effective Leakage Area and Flow Coefficient models are taken 
from the ASHRAE Handbook (2001 Chapter 26; 2005 Chapter 27), where they are referred to as 
“Basic” and “Enhanced,” respectively. 

This exercise aims to compare different infiltration data and energy usage using each of above-
mentioned models. 

Note: 
More advanced infiltration calculations are possible using the EnergyPlus Airflow Network model for natural 
infiltration driven by wind when the HVAC system doesn’t operate and/or driven by wind and forced air for times 
when the HVAC system operates.  
 
Note: 
It’s common to simplify energy models by combining all the windows on a wall or in a zone into one window of 
equivalent size. The error in estimating conductive and radiative heat transfer across the enclosure by this 
simplification is usually quite small. If the windows are a significant source of infiltration, however, this 
simplification may introduce large errors. This modification to the building design significantly reduces the linear 
area of window frame and crack and thus will underestimate the amount of infiltration that occurs. 
 
Note: About IDF Editor 
Users who want a simple way to create or edit EnergyPlus input data files (IDF) can use the IDF Editor. They can 
view and edit any EnergyPlus object using a spreadsheet-like grid. A list is provided for inputs with several options. 
The IDF Editor outputs an EnergyPlus input file with proper syntax and comments to help the user understand the 
input values. In addition, the IDF Editor converts standard inch-pound units into SI units that are compatible with 
EnergyPlus. The IDF Editor does not check inputs for validity, although it highlights some numeric fields that are 
out of range. For the purpose of this exercise, the IDF editor is a useful input interface. 
 

 



 

Note:  
These exercise instructions and associated input files have been written to conform with EnergyPlus v5.0.0 format.  
Use of these instructions and input files with later versions of EnergyPlus may require changes or updates to input 
objects and location of data sets and weather files.  
 
Exercise Procedure 

Schedules are a usage study, and the values are usually obtained from the architect’s office or 
from previous simulations of similar buildings. For this exercise, assume that the infiltration 
schedule available in the base file applies to all the models.  

Data for infiltration and coefficients are entered in their respective spaces, the data being pulled 
from the ASHRAE Handbook or from other noted sources. Simulations are run, and energy 
usage data obtained for analysis. This process is repeated for all the models described above.  

Output Data 

Before proceeding to the simulations, the idf base file should be set for the desired output data 
and format. This will help to make the idf file ready for output right after infiltration data, so the 
process does not have to be repeated for every calculation model.  

The following objects allow standard reports to be defined and utilized in EnergyPlus: 

  Output: Table: Time Bins 

  Output: Table: Monthly 

  Output: Table: Summary Reports 

  Output Control: Table: Style 

No Output: Meter or Output: Variable objects need to be specified to use the standard reports. 
The StandardReports.idf file in the DataSets directory of EnergyPlus provides a good set of 
sample reports. 

This exercise is limited to creating basic summary reports in html format.  

Instructions 

1. Start IDF Editor > File > Open >  1.InfiltrationBaseFile.idf 
2. Select Class List > Output Reporting > Output: Table: Summary Reports > New Object 

Enter the following data: 
 
Report 1 Name AnnualBuildingUtilityPerformanceSummary 

Report 2 Name EnvelopeSummary 

Report 3 Name InputVerificationandResultsSummary 

Report 4 Name ClimateDataSummary 

Report 5 Name EquipmentSummary 
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These basic reports allow for a quick analysis of the building’s performance. More 
detailed reports can be selected from the pull-down menu. 

3. Select > Class List > Output Reporting > Output Control: Table: Style > New Object 
Enter the following data: 
 
Column Separator HTML 

 
Other default styles include comma (which works well for importing data into 
spreadsheet programs such as Microsoft® Excel®), tab (for word processing programs), 
fixed, etc.  

4. Save changes to base file. 

The idf base file is now ready for infiltration data inputs. 

  p. 3 of 21 



 

DESIGN FLOW RATE MODEL 

In this model, the user defines a design flow rate that can be modified by temperature differences 
and wind speed. The calculation method selected for this exercise is Air Changes per Hour 
(ACH).  

Two simulations are run to compare differences by assuming the ACH values to be o.5ACH and 
1ACH.  

The schedule can be selected from a pull-down menu. The default values of EnergyPlus are used 
for the required coefficients (1, 0, 0, 0). This same data is entered for all 10 zones.  

0.5ACH Model: Instructions 

1. Start IDF Editor > File > Open > 1.InfiltrationBaseFile.idf 
2. Save as 2.Infiltration_DesignFlowRate_0.5ACH.idf 
3. Select Class List > Zone Airflow > Zone Infiltration: Design Flow Rate > New Object 

Create 10 new objects with the following names and zone names for each zone: 
 

Object# Name Zone Name 

Obj1 ZN_1_FLR_1_SEC_1_Infiltration ZN_1_FLR_1_SEC_1 

Obj2 ZN_1_FLR_2_SEC_1_Infiltration ZN_1_FLR_2_SEC_1 

Obj3 ZN_1_FLR_1_SEC_2_Infiltration ZN_1_FLR_1_SEC_2 

Obj4 ZN_1_FLR_2_SEC_2_Infiltration ZN_1_FLR_2_SEC_2 

Obj5 ZN_1_FLR_1_SEC_3_Infiltration ZN_1_FLR_1_SEC_3 

Obj6 ZN_1_FLR_2_SEC_3_Infiltration ZN_1_FLR_2_SEC_3 

Obj7 ZN_1_FLR_1_SEC_4_Infiltration ZN_1_FLR_1_SEC_4 

Obj8 ZN_1_FLR_2_SEC_4_Infiltration ZN_1_FLR_2_SEC_4 

Obj9 ZN_1_FLR_1_SEC_5_Infiltration ZN_1_FLR_1_SEC_5 

Obj10 ZN_1_FLR_2_SEC_5_Infiltration ZN_1_FLR_2_SEC_5 
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4. Enter the following data for all 10 zones: 
 
Schedule Name INFIL_SCH 

Design Flow Rate Calculation Method Air Changes/Hour 

Air Changes per Hour 0.5 

Constant Term Coefficient 1 

Temperature Term Coefficient 0 

Velocity Term Coefficient 0 

Velocity Squared Term Coefficient 0 
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5. Save changes. The file is now ready to simulate. 
Start > EP-Launch > Input file > Browse > Select 
2.Infiltration_DesignFlowRate_0.5ACH.idf from its destination folder. 

6. Weather File > Browse > C:\EnergyPlusV5-0-0\WeatherData\USA_IL_Chicago-
OHare.Intl.AP.725300_TMY3.epw 

7. Simulate 
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Simulation in Progress 
 

 
 
Simulation Completed 
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Sample Image of HTML Output 
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1ACH Model: Instructions 

1. Start IDF Editor > File > Open >  2.Infiltration_DesignFlowRate_0.5ACH.idf 
2. Save as 3.Infiltration_DesignFlowRate_1ACH.idf 
3. Select Class List > Zone Airflow > Zone Infiltration: Design Flow Rate  

Change Air Changes per Hour Value for all 10 objects from 0.5 to 1 
 

 
 
4. Save changes. The file is ready to simulate 

Start > EP-Launch > Input file > Browse > Select 
3.Infiltration_DesignFlowRate_1ACH.idf from its destination folder. 

5. Weather File > Browse > C:\EnergyPlusV5-0-0\WeatherData\USA_IL_Chicago-
OHare.Intl.AP.725300_TMY3.epw 

6. Simulate 
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RESULTS 

Energy End-Use Comparison 

The output graphs are created from the data in the END USES Table in the Annual Building 
Utility Performance Summary Report. 

 

 
 

 0.5ACH_model [GJ] 1ACH_model [GJ] 

Heating (Natural Gas) 272.64 372.79 

Cooling (Electricity) 44.96 55.31 
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EFFECTIVE LEAKAGE AREA MODEL 

The Effective Leakage Area model is based on Sherman and Grimsrud (1980) and accessed 
using the Zone Infiltration: Effective Leakage Area input object. The model formulation used in 
EnergyPlus is from the ASHRAE Handbook (2001 Chapter 26; 2005 Chapter 27), where it is 
referred to as the “Basic” model. 

We need to find Effective Leakage Area = AL for all zones to use this method. This exercise uses 
the accompanying spreadsheet to calculate AL for each zone.  

The spreadsheet uses data from the 1997 ASHRAE Handbook-Fundamentals, Chapter 25, Table 
3 to calculate minimum and maximum effective leakage areas based on user inputs of 
component data. 

Note:  
This method of finding AL can be wildly inaccurate, so use it with caution. 

Note: 
ASHRAE removed the table with component values from the handbook in 2005, so look at a 2001 or earlier 
handbook for additional components. Check units to see if you scale entry by area of component or the component 
edge lengths, or if value is per component 

Spreadsheet Input 

The user needs to calculate the following data (in IP Units) for each zone to enter into the 
spreadsheet in the respective zone tables: 

 Doors: number, area. 

 Windows: areas, frame perimeters 

 Exterior wall areas 

 Joint Lengths: ceiling-floor, floor-wall 

It is easier to use Google SketchUpTM to view the building zones and measure the component 
data to feed into the spreadsheet. 

OpenStudio is a free plugin for the Google SketchUp 3D drawing program. The plugin makes it 
easy to view and measure the building geometry in the EnergyPlus input files.  
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Image showing EnergyPlus object data in Google SketchUp using the OpenStudio Plugin 

The following data was measured from the building to enter into the spreadsheet: 

 ZN_1_FLR_1_SEC_1 

ZN_1_FLR_1_SEC_3 

ZN_1_FLR_1_SEC_2 

ZN_1_FLR_1_SEC_4 

ZN_1_FLR_2_SEC_1 

ZN_1_FLR_2_SEC_3 

ZN_1_FLR_2_SEC_2 

ZN_1_FLR_2_SEC_4 

ZN_1_FLR_1_SEC_5 

ZN_1_FLR_2_SEC_5 

Units 

Door Frame 1 1 0 0 0  ea
Door Double 36.4154 36.4154 0 0 0 ft2

Window Framing 237.85 100.42 255.0707 117.7064 0 ft2

Window Double- 2498.125 91.21 217.55 105.22 0 lftc
Walls Sheathing 834.688 374.9063 853.8812 394.0907 0 ft2

Ceiling-Wall 104.0625 48 104.0625 48 184.625 lftc
Floor-Wall Joint 104.0625 48 104.0625 48 184.625 lftc

 

Note:  
Symmetry of the building zones on each floor allows us to use the same data for two zones. 
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This exercise involves simulation and comparison of energy usage based on minimum and 
maximum leakage areas calculated by the spreadsheet. 

Stack Coefficient and Wind Coefficient values are calculated from the 2009 ASHRAE 
Handbook, Chapter 16, Tables 4-6, for a building height of 20 feet, Shelter Class 5. 

1. Stack Coefficient = Cs = 0.0003625 (L/s)2/(cm4.K) 
2. Wind Coefficient = Cw = 0.0000455 (L/s)2/[cm4.(m/s)2] 

Minimum Leakage Area Model: Instructions 

1. Start IDF Editor > File > Open >  1.InfiltrationBaseFile.idf 
2. Save as 4.Infiltration_EffectiveLeakageArea_min.idf 
3. Select Class List > Zone Airflow > Zone Infiltration: Effective Leakage Area > New 

Object 
Create 10 new objects with the following names and zone names for each zone: 

 

Object# Name Zone Name Effective Air Leakage Area

Obj1 ZN_1_FLR_1_SEC_1_Infiltration ZN_1_FLR_1_SEC_1 401.83 

Obj2 ZN_1_FLR_2_SEC_1_Infiltration ZN_1_FLR_2_SEC_1 85.70 

Obj3 ZN_1_FLR_1_SEC_2_Infiltration ZN_1_FLR_1_SEC_2 48.58 

Obj4 ZN_1_FLR_2_SEC_2_Infiltration ZN_1_FLR_2_SEC_2 40.20 

Obj5 ZN_1_FLR_1_SEC_3_Infiltration ZN_1_FLR_1_SEC_3 401.83 

Obj6 ZN_1_FLR_2_SEC_3_Infiltration ZN_1_FLR_2_SEC_3 85.70 

Obj7 ZN_1_FLR_1_SEC_4_Infiltration ZN_1_FLR_1_SEC_4 48.58 

Obj8 ZN_1_FLR_2_SEC_4_Infiltration ZN_1_FLR_2_SEC_4 40.20 

Obj9 ZN_1_FLR_1_SEC_5_Infiltration ZN_1_FLR_1_SEC_5 13.22 

Obj10 ZN_1_FLR_2_SEC_5_Infiltration ZN_1_FLR_2_SEC_5 13.22 

 

4. Enter the following data for all 10 zones: 
 
Schedule Name INFIL_SCH 

Stack Coefficient 0.0003625 

Wind Coefficient 0.0000455 
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5. Save changes. The file is now ready to simulate. 
6. Start > EP-Launch > Input file > Browse > Select 

4.Infiltration_EffectiveLeakageArea_min.idf from its destination folder. 
7. Weather File > Browse > C:\EnergyPlusV5-0-0\WeatherData\USA_IL_Chicago-

OHare.Intl.AP.725300_TMY3.epw 
8. Simulate 
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Maximum Leakage Area Model: Instructions 

1. Start IDF Editor > File > Open > 4.Infiltration_EffectiveLeakageArea_min.idf 
2. Save as 5.Infiltration_EffectiveLeakageArea_max.idf 
3. Select Class List > Zone Air Flow > Zone Infiltration: Effective Leakage Area  
4. Enter the following Maximum Effective Leakage Area data changing the previous 

values: 
 

Object# Name Zone Name Effective Air Leakage Area

Obj1 ZN_1_FLR_1_SEC_1_Infiltration ZN_1_FLR_1_SEC_1 1059.79 

Obj2 ZN_1_FLR_2_SEC_1_Infiltration ZN_1_FLR_2_SEC_1 265.95 

Obj3 ZN_1_FLR_1_SEC_2_Infiltration ZN_1_FLR_1_SEC_2 218.62 

Obj4 ZN_1_FLR_2_SEC_2_Infiltration ZN_1_FLR_2_SEC_2 124.18 

Obj5 ZN_1_FLR_1_SEC_3_Infiltration ZN_1_FLR_1_SEC_3 1059.79 

Obj6 ZN_1_FLR_2_SEC_3_Infiltration ZN_1_FLR_2_SEC_3 265.95 

Obj7 ZN_1_FLR_1_SEC_4_Infiltration ZN_1_FLR_1_SEC_4 218.62 

Obj8 ZN_1_FLR_2_SEC_4_Infiltration ZN_1_FLR_2_SEC_4 124.18 

Obj9 ZN_1_FLR_1_SEC_5_Infiltration ZN_1_FLR_1_SEC_5 208.21 

Obj10 ZN_1_FLR_2_SEC_5_Infiltration ZN_1_FLR_2_SEC_5 208.21 

 
5. Save changes. The file is now ready to simulate. 
6. Start > EP-Launch > Input file > Browse > Select 

5.Infiltration_EffectiveLeakageArea_max.idf from its destination folder. 
7. Weather File > Browse > C:\EnergyPlusV5-0-0\WeatherData\USA_IL_Chicago-

OHare.Intl.AP.725300_TMY3.epw 
8. Simulate 
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RESULTS 

Energy End Use Comparison 

The output graphs are created from the data in the END USES Table in the Annual Building 
Utility Performance Summary Report. 

 

 

 

  min_Eff_Leakage_Area [GJ] max_Eff_Leakage_Area [GJ] 

Heating (Natural Gas) 208.55 251.89 

Cooling (Electricity) 44.28 48.40 
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FLOW COEFFICIENT MODEL 

The Flow Coefficient model is based on Walker and Wilson (1998) and accessed using the Zone 
Infiltration: Flow Coefficient input object. The model formulation used in EnergyPlus is from the 
ASHRAE Handbook (2001 Chapter 26; 2005 Chapter 27), where it is referred to as the 
“Enhanced” or “AIM-2” model. 

We need to calculate flow coefficients for all zones to use this method. This exercise uses the 
accompanying spreadsheet to calculate the flow coefficients using the minimum and maximum 
effective leakage areas calculated in the earlier exercise.  

This exercise involves simulation and comparison of energy usage based on minimum and 
maximum flow coefficients calculated by the spreadsheet. 

Stack coefficient, shelter factor and wind coefficient values are calculated from the 2009 
ASHRAE Handbook, Chapter 16, Tables 6-9, for a building height of 20 feet, Shelter Class 5, no 
flue assumed. 

1. Stack Coefficient = Cs = 0.088 (Pa/K)n 
2. Wind Coefficient = Cw = 0.17 (Pa.s2/m2)n 
3. Shelter Factor = s = 0.30 
4. Pressure Exponent = 0.67 (default) 
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Flow Coefficient Model_Minimum: Instructions 

1. Start IDF Editor > File > Open >  1.InfiltrationBaseFile.idf 
2. Save as 6.Infiltration_FlowCoefficient_min.idf 
3. Select Class List > Zone Airflow > Zone Infiltration: Flow Coefficient > New Object 

Create 10 new objects with the following data for each zone: 
 

Object# Name Zone Name Flow Coefficient 

Obj1 ZN_1_FLR_1_SEC_1_Infiltration ZN_1_FLR_1_SEC_1 0.0398 

Obj2 ZN_1_FLR_2_SEC_1_Infiltration ZN_1_FLR_2_SEC_1 0.0085 

Obj3 ZN_1_FLR_1_SEC_2_Infiltration ZN_1_FLR_1_SEC_2 0.0048 

Obj4 ZN_1_FLR_2_SEC_2_Infiltration ZN_1_FLR_2_SEC_2 0.0040 

Obj5 ZN_1_FLR_1_SEC_3_Infiltration ZN_1_FLR_1_SEC_3 0.0398 

Obj6 ZN_1_FLR_2_SEC_3_Infiltration ZN_1_FLR_2_SEC_3 0.0085 

Obj7 ZN_1_FLR_1_SEC_4_Infiltration ZN_1_FLR_1_SEC_4 0.0048 

Obj8 ZN_1_FLR_2_SEC_4_Infiltration ZN_1_FLR_2_SEC_4 0.0040 

Obj9 ZN_1_FLR_1_SEC_5_Infiltration ZN_1_FLR_1_SEC_5 0.0013 

Obj10 ZN_1_FLR_2_SEC_5_Infiltration ZN_1_FLR_2_SEC_5 0.0013 

 

4. Enter the following data for all 10 zones: 
 
Schedule Name INFIL_SCH 

Stack Coefficient 0.088 

Pressure Exponent 0.67 

Wind Coefficient 0.17 

Shelter Factor 0.3 
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5. Save changes. The file is now ready to simulate. 
6. Start > EP-Launch > Input file > Browse > Select 6.Infiltration_FlowCoefficient_min.idf 

from its destination folder. 
7. Weather File > Browse > C:\EnergyPlusV5-0-0\WeatherData\USA_IL_Chicago-

OHare.Intl.AP.725300_TMY3.epw 
8. Simulate 
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Flow Coefficient Model_Maximum: Instructions 

1. Start IDF Editor > File > Open > 6.Infiltration_FlowCoefficient_min.idf 
2. Save as 7.Infiltration_ FlowCoefficient _max.idf 
3. Select Class List > Zone Air Flow > Zone Infiltration: Flow Coefficient  
4. Enter the following Flow Coefficient data changing the previous values: 
 

Object# Name Zone Name Flow Coefficient 

Obj1 ZN_1_FLR_1_SEC_1_Infiltration ZN_1_FLR_1_SEC_1 0.1048 

Obj2 ZN_1_FLR_2_SEC_1_Infiltration ZN_1_FLR_2_SEC_1 0.0263 

Obj3 ZN_1_FLR_1_SEC_2_Infiltration ZN_1_FLR_1_SEC_2 0.0216 

Obj4 ZN_1_FLR_2_SEC_2_Infiltration ZN_1_FLR_2_SEC_2 0.0123 

Obj5 ZN_1_FLR_1_SEC_3_Infiltration ZN_1_FLR_1_SEC_3 0.1048 

Obj6 ZN_1_FLR_2_SEC_3_Infiltration ZN_1_FLR_2_SEC_3 0.0263 

Obj7 ZN_1_FLR_1_SEC_4_Infiltration ZN_1_FLR_1_SEC_4 0.0216 

Obj8 ZN_1_FLR_2_SEC_4_Infiltration ZN_1_FLR_2_SEC_4 0.0123 

Obj9 ZN_1_FLR_1_SEC_5_Infiltration ZN_1_FLR_1_SEC_5 0.0206 

Obj10 ZN_1_FLR_2_SEC_5_Infiltration ZN_1_FLR_2_SEC_5 0.0206 

 
5. Save changes. The file is now ready to simulate. 
6. Start > EP-Launch > Input file > Browse > Select 7.Infiltration_FlowCoefficient_max.idf 

from its destination folder. 
7. Weather File > Browse > C:\EnergyPlusV5-0-0\WeatherData\USA_IL_Chicago-

OHare.Intl.AP.725300_TMY3.epw 
8. Simulate 

 

  p. 20 of 21 



 

RESULTS 

Energy End-Use Comparison 

The output graphs are created from the data in END USES Table in the Annual Building Utility 
Performance Summary Report. 

 

 
 
 
  Flow_Coefficient_min [GJ] Flow_Coefficient_max [GJ] 

Heating (Natural Gas) 203.28 232.66 

Cooling (Electricity) 44.02 47.10 

 
 

This material is based upon work supported by the U.S. Department of Energy under Award Number DE-FG26-
07NT43330 to the Alliance to Save Energy. All material Copyright 2010 U.S. Department of Energy. All rights 
reserved. 
 
This document was prepared as an account of work sponsored by an agency of the United States Government. 
Neither the United States Government nor any agency thereof, nor any of their employees, makes any warranty, 
expressed or implied, or assumes any legal liability or responsibility for the accuracy, completeness, or usefulness of 
any information, apparatus, product, or process disclosed, or represents that its use would not infringe privately 
owned rights. Reference herein to any specific commercial product, process, or service by trade name, trademark, 
manufacturer, or otherwise does not necessarily constitute or imply its endorsement, recommendation, or favoring 
by the United States Government or any agency thereof. The views and opinions of authors expressed herein do not 
necessarily state or reflect those of the United States Government or any agency thereof. 
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