
 

 

INTERNAL GAINS MODULE—ENERGYPLUS EXERCISE INSTRUCTIONS 

Exercise Introduction and Objectives 

The exercise provides a base file for a two-story building, measuring 104 x 48. The building is 
modeled with core and perimeter zoning for each floor.  

The objective of this exercise is to study the effect of internal gains from people, lighting and 
equipment on a building’s energy use. The same structure is modeled as a hotel, an office and a 
retail building with different space-use characteristics, lighting plans and equipment data to study 
the difference in energy consumption.  

Note:  
These exercise instructions and associated input files have been written to conform with EnergyPlus v5.0.0 format.  
Use of these instructions and input files with later versions of EnergyPlus may require changes or updates to input 
objects and location of data sets and weather files.  
 

Exercise Procedure 

Schedules are a usage study, and the values are usually obtained from the architect’s office or 
from previous simulations of similar buildings. Schedules are created for activity, work 
efficiency, air velocity and clothing. Schedules for people occupancy and lighting are imported 
from Eplus datasets for the three models. 

Data for internal gains from people, lighting and equipment is entered in the respective spaces, 
the data being pulled from the ASHRAE Handbook or from the plethora of predefined material 
and schedule data that comes with EnergyPlus.  

Simulations are run and energy usage data obtained for analysis. 

Note: About IDF Editor 
Users who want a simple way to create or edit EnergyPlus input data files (IDF) can use the IDF Editor. They can 
view and edit any EnergyPlus object using a spreadsheet-like grid. A list is provided for inputs with several options. 
The IDF Editor outputs an EnergyPlus input file with proper syntax and comments to help the user understand the 
input values. In addition, the IDF Editor converts standard inch-pound units into SI units that are compatible with 
EnergyPlus. The IDF Editor does not check inputs for validity, although it highlights some numeric fields that are 
out of range. For the purpose of this exercise, the IDF editor is a useful input interface. 
 

 



 

Hotel Building Data 

A hotel hopes to have a fairly constant activity load. Although there is lower activity at night 
than during the day, the variation is not as great as in residential or other commercial locations.   

For this exercise assume that the activity level of people within the space is uniform for the day 
and for all days of the year at 120 W/person. All building zones will have the same activity level. 

Instructions 

1. Start IDF Editor > File > Open > 1.Base File.idf 
2. Save as > 2.HotelBldg.idf  in the destination folder. 
3. Under Class List, select Schedules > Schedule: Compact > New Object 
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4. Create a schedule for Activity with the following data: 
 

Name ACTIVITY_SCH 

Schedule Type Limits Name Any number 

Field 1 Through: 12/31 

Field 2 For: AllDays 

Field 3 Until: 24:00 

Field 4 120. 
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5. Similarly create schedules for work efficiency, air velocity, clothing with the following 
data:  
 

Name WORK_EFF_SCH

Schedule Type Limits Name Fraction 

Field 1 Through: 12/31 

Field 2 For: AllDays 

Field 3 Until: 24:00 

Field 4 0.0 

 
Name AIR_VELO_SCH 

Schedule Type Limits Name Any Number 

Field 1 Through: 12/31 

Field 2 For: AllDays 

Field 3 Until: 24:00 

Field 4 0.2 

 
Name CLOTHING_SCH 

Schedule Type Limits Name Any Number 

Field 1 Through: 04/30 

Field 2 For: AllDays 

Field 3 Until: 24:00 

Field 4 1.0 

Field 5 Through: 09/30 

Field 6 For: AllDays 

Field 7 Until: 24:00 

Field 8 0.5 

Field 9 Through: 12/31 

Field 10 For: AllDays 

Field 11 Until: 24:00 

Field 12 1.0 
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6. Obtain the occupancy and lighting use schedules for typical hotels from the EnergyPlus 
database. 
To import people, lighting schedules from the database: 

a) File > Open Dataset > Schedules.idf 
b) Open Class List > Schedules > Schedule:Compact 
c) Look for Hotel Lighting Schedule > Copy Object 
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d) Paste Object into 2.HotelBldg.idf 
e) Repeat the same process with Hotel Occupancy Schedule. 

 
f) For the HVAC Operation Schedule (Obj12), for Weekdays SummerDesignDays, 

Until: 24:00, change Field 8 from 0.0 to 1.0.   
g) The schedules are complete. We now need to enter the data needed for internal 

gains input. 

7. The next step is to add the actual internal gains. One good source of data is the Lawrence 
Berkeley National Laboratory (LBNL) report, Commercial Heating and Cooling Loads 
Component Analysis, June 1998, http://gundog.lbl.gov/dirpubs/37208.pdf.   
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8. Add the internal gains for people. 
Input for Hotel building: Internal Gains: People 
Select Class List > Internal Gains > People 
The base file contains 10 objects with names for input fields and the zone names. 

 
The choice selected for calculation method in this exercise is Zone Floor Area per person, 
and the values for Hotel building type are obtained from Table 12 on page 33 of the 
LBNL report mentioned above. For the small hotel, the suggested value of 120 ft2/person 
= 11.15 m2/person is taken. The schedules can be selected from a pull-down menu. This 
same data is entered for all 10 zones.  
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The full set of data for input is as follows: 
 

Number of People Schedule Name Hotel Occupancy 
Number of People Calculation Method Area/Person 
Zone Floor Area per Person (m2/person) 11.15 
Fraction Radiant 0.3 
Sensible Heat Fraction Autocalculate 
Activity Level Schedule Name ACTIVITY_SCH 
Enable ASHRAE 55 Comfort Warnings Yes 
Mean Radiant Temperature Calculation Type ZoneAveraged 
Work Efficiency Schedule Name WORK_EFF_SCH 
Clothing Insulation Schedule Name CLOTHING_SCH 
Air Velocity Schedule Name AIR_VELO_SCH 
Thermal Comfort Model 1Type Fanger 
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9. Input for Internal Gains: Lights 
Similar to the People section, the base file contains 10 objects with names for input fields 
and the zone names. The choice selected for calculation method in this exercise is Watts 
per Zone Floor Area, and the values for each building type are obtained from the LBNL 
Heating and Cooling loads report. The data entered for all 10 zones is same.  
 
For the small hotel, the suggested value of 1.06 W/ft2 = 11.42 W/m2 is taken from Table 
12 on page 33 of the LBNL report. Since the value is within the allowed lighting power 
density of ASHRAE 90.1, we will use this value for the simulation. The lighting gain is a 
combination of many differing types, so a 70 percent radiant fraction is assumed. 
 
Select Class List > Internal Gains > Lights and input the data as follows: 

Schedule name Hotel Lighting 
Design Level Calculation Method Watts/Area 
Watts per Zone Floor area (W/m2) 11.42 
Return Air Fraction 0 
Fraction Radiant 0.7 
Fraction Visible 0.2 
Fraction Replaceable 1 
End-Use Subcategory General 
Return Air Fraction Calculated from Plenum Temperature No 
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10. Now we have to input internal gains from electrical equipment. There are several ways to 
do so, but one of the easiest is to assume some level of power per unit area. The data used 
here are obtained from Table 12, p. 33 of the LBNL report. 
 
This report suggests using the value 0.69 W/ft2 =7.43 W/m2 for a small hotel. Since the 
electrical equipment load is a combination of small motor appliances and small 
electronics, a 50 percent radiant fraction should be used. 
 
The schedule for equipment is assumed to be the same as Hotel Lighting. 
The data for inputting in all 10 zones is as follows: 
 

Schedule Name Hotel Lighting
Design Level Calculation Method Watts/Area 
Watts per Zone Floor Area (W/m2) 7.43 
Fraction Latent 0 
Fraction Radiant 0.5 
Fraction Lost 0 
End-Use Subcategory General 
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11. All data required for Hotel-Building Internal Gains is entered into the idf file, which now 
needs to be set up for required output. 

Output Data 

The following objects allow standard reports to be defined and utilized in EnergyPlus: 

  Output: Table: Time Bins 

  Output: Table: Monthly 

  Output: Table: Summary Reports 

  Output Control: Table: Style 

No Output: Meter or Output: Variable objects need to be specified to use the standard reports. A 
good set of sample reports is available in the StandardReports.idf file in the DataSets directory of 
EnergyPlus. 

This exercise is limited to creating basic summary reports in html format and monthly Output 
Tables for Occupant Comfort Data. 

Instructions (continued) 

12. Select Class List > Output Reporting > Output: Table: Summary Reports > New Object 
Enter the following data: 
 
Report 1 Name AnnualBuildingUtilityPerformanceSummary 

Report 2 Name EnvelopeSummary 

Report 3 Name InputVerificationandResultsSummary 

Report 4 Name ClimateDataSummary 

Report 5 Name EquipmentSummary 

 
These are basic reports that allow for a quick analysis of the building’s performance. 
More detailed reports can be selected from the pull-down menu for in-depth analysis. 
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13. Select Class List > Output Reporting > Output: Table: Monthly > New Object 
Enter the following data:  

Name Occupant Comfort Data Summary 

Digits After Decimal 3 

Variable or Meter 1 Name People Number of Occupants 

Aggregation Type for Variable or Meter 1 HoursNonZero 

Variable or Meter 2 Name ThermalComfortMRT 

Aggregation Type for Variable or Meter 2 SumOrAverageDuringHoursShown 

Variable or Meter 3 Name FANGERPMV 

Aggregation Type for Variable or Meter 3 SumOrAverageDuringHoursShown 

 
This data gives the monthly Occupant Comfort Data in the entered variables for each 
zone. 

14. Select > Class List > Output Reporting > Output Control: Table Style > New Object 
Enter the following data: 
 
Column Separator HTML 

 
Other default styles include comma (which works well for importing data into 
spreadsheet programs such as Microsoft® Excel®), tab (for word processing programs), 
fixed, etc.  
The idf file is now ready for simulation after saving changes as 2.HotelBldg.idf 

15. Start > EP-Launch > Input file > Browse > Select 2.HotelBldg.idf from its destination 
folder. 

16. Weather File > Browse > C:\EnergyPlusV5-0-0\WeatherData\USA_IL_Chicago-
OHare.Intl.AP.725300_TMY3.epw 

17. Simulate 
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Simulation in Process  

 

Simulation Completed 
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Sample Image of HTML Output 
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Office Building Data 

1. The process above is to be repeated for an office building. Start with the Hotel and save 
as 3.OfficeBldg.idf 

2. The activity, work efficiency, air velocity and clothing schedules remain the same for all 
modules. 

3. Office occupancy and office lighting schedules are imported from the same dataset as 
earlier.  For office occupancy schedule, for Sunday Holidays, Until: 18:00, change 0.05 
to 0.0. 

4. Input for Office Building: Internal Gains: People 
Occupancy data taken from Table 10 of Page 31 of the LBNL Report for a small office is 
470 ft2/person = 43.66 m2/person 
The full data set to be input is: 
 

Number of People Schedule Name Office Occupancy 
Number of People Calculation Method Area/Person 
Zone Floor Area per Person (m2/person) 43.66 
Fraction Radiant 0.3 
Sensible Heat Fraction Autocalculate 
Activity Level Schedule Name ACTIVITY_SCH 
Enable ASHRAE 55 Comfort Warnings Yes 
Mean Radiant Temperature Calculation Type ZoneAveraged 
Work Efficiency Schedule Name WORK_EFF_SCH 
Clothing Insulation Schedule Name CLOTHING_SCH 
Air Velocity Schedule Name AIR_VELO_SCH 
Thermal Comfort Model 1Type Fanger 

 

5. Input for Office Building: Internal Gains: Lighting 
The suggested value from Table 10, p. 31 of the LBNL report is a lighting gain of 1.7 
W/ft2 which is in excess of the most current ASHRAE 90.1 allowance. Thus, we will 
assume that the building being simulated has only a lighting gain of only 1.1 W/ft2 = 11.8 
W/m2.   
The full data set to be input is: 
 

Schedule Name Office Lighting 
Design Level Calculation Method Watts/Area 
Watts per Zone Floor Area (W/m2) 11.8 
Return Air Fraction 0 
Fraction Radiant 0.7 
Fraction Visible 0.2 
Fraction Replaceable 1 
End-Use Subcategory General 
Return Air Fraction Calculated from Plenum Temperature No 
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6. Input for Office Building: Internal Gains: Electric Equipment 

From the LBNL report the suggested equipment power density is 0.5 W/ft2 = 5.385 
W/m2. The full data set for inputting into all 10 zones is: 
 

Schedule Name Office Lighting

Design Level Calculation Method Watts/Area 

Watts per Zone Floor Area (W/m2) 5.385 

Fraction Latent 0 

Fraction Radiant 0.5 

Fraction Lost 0 

End-Use Subcategory General 

 
7. Repeat the output setup instructions for this file. 
8. Simulations can be run for Office Building with entered data after saving changes. 
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Retail Building Data 

1. The process above is to be repeated for a retail building. Start with the Office and save as 
4.RetailBldg.idf 

2. Import retail occupancy, retail lighting schedules from the same dataset as earlier. 
3. Input for Retail Building: Internal Gains: People 

The people gain data comes from Table 11, p. 32 of the LBNL report and is an 
occupancy of 1635 ft2/person = 151.89 m2/person.   
The full data set is:  
 

Number of People Schedule Name Retail Occupancy 

Number of People Calculation Method Area/Person 

Zone Floor Area per Person (m2/person) 151.89 

Fraction Radiant 0.3 

Sensible Heat Fraction Autocalculate 

Activity Level Schedule Name ACTIVITY_SCH 

Enable ASHRAE 55 Comfort Warnings Yes 

Mean Radiant Temperature Calculation Type ZoneAveraged 

Work Efficiency Schedule Name WORK_EFF_SCH 

Clothing Insulation Schedule Name CLOTHING_SCH 

Air Velocity Schedule Name AIR_VELO_SCH 

Thermal Comfort Model 1Type Fanger 

 
4. Input for Retail Building: Internal Gains: Lighting 

The lighting gain data comes from Table 11, p. 32 of the LBNL report and is a lighting 
power density of 1.7 W/ft2 = 18.31 W/m2.  
The full data set is: 
 

Schedule Name Retail Lighting 

Design Level Calculation Method Watts/Area 

Watts per Zone Floor area (W/m2) 18.31 

Return Air Fraction 0 

Fraction Radiant 0.7 

Fraction Visible 0.2 

Fraction Replaceable 1 

End-Use Subcategory General 

Return Air Fraction Calculated from Plenum Temperature No 
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5. Input for Retail Building: Internal Gains: Electric Equipment 
The data from Table 11, p. 32 of the LBNL report is 0.5W/ft2 = 5.385 W/m2. 
The full data set is: 
 

Schedule Name Retail Lighting
Design Level Calculation Method Watts/Area 
Watts per Zone Floor Area (W/m2) 5.385 
Fraction Latent 0 
Fraction Radiant 0.5 
Fraction Lost 0 
End-Use Subcategory General 

 
6. Repeat the output setup instructions for this file. 
7. Run simulations after saving changes. 
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RESULTS 

Energy End Use Comparison 

The output graphs are created from the data in END USE Table in the Annual Building 
Utility Performance Summary Report. 
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 Retail [GJ] Hotel [GJ] Office [GJ] 

Heating 
(Nat. Gas) 196.24 148.08 227.03 

Cooling 
(Elect.) 47.20 56.02 43.87 

Int. Lighting 
(Elect.) 115.63 89.35 56.47 

Int. Equipment 
(Elect) 65.41 75.85 51.48 
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Thermal Comfort Data: Fanger PMV Comparison 

The output graphs (for core zone of ground floor) are created from the data in 
ZN_1_FLR_1_SEC_5 PEOPLE Table in the Occupant Comfort Data Summary Report. 
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For: ZN_1_FLR_1_SEC_5 PEOPLE Hotel Building Retail Building Office Building 

Jan -0.74 -0.72 -0.72 

Feb -0.64 -0.64 -0.68 

Mar -0.38 -0.44 -0.54 

Apr -0.13 -0.25 -0.36 

May -0.81 -1.05 -1.30 

Jun -0.37 -0.60 -0.74 

Jul -0.14 -0.43 -0.59 

Aug -0.24 -0.49 -0.65 

Sep -0.45 -0.70 -0.94 

Oct 0.02 -0.18 -0.33 

Nov -0.38 -0.44 -0.50 

Dec -0.69 -0.68 -0.69 
 
Note: 
An environment is considered acceptable for thermal comfort when -0.5 < PMV < 0.5. 
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